Install Python Client
Everything you need to install and run a TerminusDB Python client

Requirements

A list of prerequisite components depending on your operating system. Click on the required component to download it from the provider's website.
Installation requirements
Required
Version
Required to:
Linux
macOS
Windows
Latest
Install the TerminusDB server as a Docker container.
Git
Latest
Build and install the Python client from source.
GitBash
Latest
Use the Python CLI (recommended shell.)
Python
3.6+
Use the TerminusDB Python client.

Install steps

Install and use the TerminusDB Python client with the following steps.

Install the TerminusDB bootstrap

Install the TerminusDB server terminusdb-server as a Docker container.

Install the latest Python components

In an administrator shell, run the command below to update pip, setuptools, and wheel.
Linux/macOS
Windows
python3 -m pip install --upgrade pip setuptools wheel
py -m pip install --upgrade pip setuptools wheel

Install the TerminusDB Python client

Choose one of the following Python client install options.

Install the core

Install the core Python client. The core includes WOQLClient and WOQLQuery.
python -m pip install terminusdb-client

Install with dataframe

Install the Python client with the WOQL dataframe. The WOQLDataFrame enables query results to be converted to different formats such as Pandas.
python -m pip install terminusdb-client[dataframe]
If you are using a shell other than bash, such as zsh, you may need to use quotes.
python -m pip install 'terminusdb-client[dataframe]'

Install from source

Build and install the Python client from source.
python -m pip install git+https://github.com/terminusdb/terminusdb-client-python.git

Further reading

Export as PDF
Copy link
On this page
Requirements
Install steps
Further reading